$re = '/(\w+.|^)facebook(?!.*(cpc|referral))/m';
$str = 'facebook/cpc/[facebook][cpc][house][sale]
facebook/cpc/[facebook][cpc][condo][sale]
facebook/referral/[facebook][marketplace][condo][rent]
facebook/referral/[facebook][marketplace][house][rent]
m.facebook.com
facebook.com
l.facebook.com
free.facebook.com
web.facebook.com
mobile.facebook.com
lm.facebook.com
facebook/social/listing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);