import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+.|^)facebook(?!.*(cpc|referral))";
final String string = "facebook/cpc/[facebook][cpc][house][sale]\n"
+ "facebook/cpc/[facebook][cpc][condo][sale]\n"
+ "facebook/referral/[facebook][marketplace][condo][rent]\n"
+ "facebook/referral/[facebook][marketplace][house][rent]\n"
+ "m.facebook.com\n"
+ "facebook.com\n"
+ "l.facebook.com\n"
+ "free.facebook.com\n"
+ "web.facebook.com\n"
+ "mobile.facebook.com\n"
+ "lm.facebook.com\n"
+ "facebook/social/listing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}