using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+.|^)facebook(?!.*(cpc|referral))";
string input = @"facebook/cpc/[facebook][cpc][house][sale]
facebook/cpc/[facebook][cpc][condo][sale]
facebook/referral/[facebook][marketplace][condo][rent]
facebook/referral/[facebook][marketplace][house][rent]
m.facebook.com
facebook.com
l.facebook.com
free.facebook.com
web.facebook.com
mobile.facebook.com
lm.facebook.com
facebook/social/listing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}