use strict;
my $str = 'facebook/cpc/[facebook][cpc][house][sale]
facebook/cpc/[facebook][cpc][condo][sale]
facebook/referral/[facebook][marketplace][condo][rent]
facebook/referral/[facebook][marketplace][house][rent]
m.facebook.com
facebook.com
l.facebook.com
free.facebook.com
web.facebook.com
mobile.facebook.com
lm.facebook.com
facebook/social/listing';
my $regex = qr/(\w+.|^)facebook(?!.*(cpc|referral))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}