import Foundation
let pattern = #"(.*)\((.*)\)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Vithursan (Je suis occupé) 06 59 15 61 49"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}