use strict;
my $str = 'Vithursan (Je suis occupé) 06 59 15 61 49';
my $regex = qr/(.*)\((.*)\)(.*)/p;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";