# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\((.*)\)(.*)/$3/;t' <<< "Vithursan (Je suis occupé) 06 59 15 61 49"