# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<AUDT:INFO>.* Passwordstate:"
test_str = "08 21 2020 08:03:24 10.62.1.17 <AUDT:INFO> 2020-08-21 08:02:25 10.62.1.17 Passwordstate: A scheduled Account Heartbeat check successfully validated the password for the Active Directory account fakedomain\\FakeUser (\\Private Credentials\\dv\\Domain). Client IP Address = 10.62.1.17. PasswordListID = 32, PasswordID = 39"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.