using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<AUDT:INFO>.* Passwordstate:";
string input = @"08 21 2020 08:03:24 10.62.1.17 <AUDT:INFO> 2020-08-21 08:02:25 10.62.1.17 Passwordstate: A scheduled Account Heartbeat check successfully validated the password for the Active Directory account fakedomain\FakeUser (\Private Credentials\dv\Domain). Client IP Address = 10.62.1.17. PasswordListID = 32, PasswordID = 39";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}