import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<AUDT:INFO>.* Passwordstate:";
final String string = "08 21 2020 08:03:24 10.62.1.17 <AUDT:INFO> 2020-08-21 08:02:25 10.62.1.17 Passwordstate: A scheduled Account Heartbeat check successfully validated the password for the Active Directory account fakedomain\\FakeUser (\\Private Credentials\\dv\\Domain). Client IP Address = 10.62.1.17. PasswordListID = 32, PasswordID = 39";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}