import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{3})-([A-Z]{3})-([A-Z]{3})";
final String string = "Welcome to RegExr v2.0 by gskinner.com!\n\n"
+ "Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save & Share expressions with friends or the Community. A full Reference & Help is available in the Library, or watch the video Tutorial.\n"
+ " pippo \n"
+ "Sample text for testing:\n"
+ "abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
+ "abcdefghijk.lmn.opqrstuvwxyz ABCD.EFG.HIJKLMN-OPQ-RSTUVWXYZ\n"
+ "0123456789 +-.,!@#$%^&*();\\/|<>\"'\n"
+ "12345 -98.7 3.141 .6180 9,000 +42\n"
+ "555.123.4567 +1-(800)-555-2468\n"
+ "foo@demo.net bar.ba@test.co.uk\n"
+ "www.demo.com http://foo.co.uk/\n"
+ "http://regexr.com/foo.html?q=bar";
final String subst = "==> sostituto: $3:$1:$2 ==> originale: **$&**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}