#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Z]{3})-([A-Z]{3})-([A-Z]{3})"
Local $sString = "Welcome to RegExr v2.0 by gskinner.com!" & @CRLF & _
"" & @CRLF & _
"Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save & Share expressions with friends or the Community. A full Reference & Help is available in the Library, or watch the video Tutorial." & @CRLF & _
" pippo " & @CRLF & _
"Sample text for testing:" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"abcdefghijk.lmn.opqrstuvwxyz ABCD.EFG.HIJKLMN-OPQ-RSTUVWXYZ" & @CRLF & _
"0123456789 +-.,!@#$%^&*();\/|<>"'" & @CRLF & _
"12345 -98.7 3.141 .6180 9,000 +42" & @CRLF & _
"555.123.4567 +1-(800)-555-2468" & @CRLF & _
"foo@demo.net bar.ba@test.co.uk" & @CRLF & _
"www.demo.com http://foo.co.uk/" & @CRLF & _
"http://regexr.com/foo.html?q=bar"
Local $sSubst = "==> sostituto: $3:$1:$2 ==> originale: **$&**"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)