# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z]{3})-([A-Z]{3})-([A-Z]{3})/==> sostituto: $3:$1:$2 ==> originale: **$&**/mg;t' <<< "Welcome to RegExr v2.0 by gskinner.com!
Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save & Share expressions with friends or the Community. A full Reference & Help is available in the Library, or watch the video Tutorial.
pippo
Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijk.lmn.opqrstuvwxyz ABCD.EFG.HIJKLMN-OPQ-RSTUVWXYZ
0123456789 +-.,!@#$%^&*();\/|<>\"'
12345 -98.7 3.141 .6180 9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co.uk/
http://regexr.com/foo.html?q=bar"