import Foundation
let pattern = #"\s*\(\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*(?:'[ifbIFB]{1}')\,\s*(?:'[0-9]{8}')\,\s*(?:'[0-9]{8}')\)\s*\,\s*\n*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
('BAR', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC LON', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC-OTC', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARINTL', 'BARCGB33XXX', 'B', '00010101', '99991231'),
('BCIEXUS', 'MLPFUS31XXX', 'B', '00010101', '99991231')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}