// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*\(\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*(?:'[ifbIFB]{1}')\,\s*(?:'[0-9]{8}')\,\s*(?:'[0-9]{8}')\)\s*\,\s*\n*").unwrap();
let string = "('BAR', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC LON', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC-OTC', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARINTL', 'BARCGB33XXX', 'B', '00010101', '99991231'),
('BCIEXUS', 'MLPFUS31XXX', 'B', '00010101', '99991231')";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}