const regex = /\s*\(\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*(?:'[ifbIFB]{1}')\,\s*(?:'[0-9]{8}')\,\s*(?:'[0-9]{8}')\)\s*\,\s*\n*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\(\\s*(?:\'[-\\\/a-zA-Z 0-9]{1,40}\')\\,\\s*\\s*(?:\'[-\\\/a-zA-Z 0-9]{1,40}\')\\,\\s*(?:\'[ifbIFB]{1}\')\\,\\s*(?:\'[0-9]{8}\')\\,\\s*(?:\'[0-9]{8}\')\\)\\s*\\,\\s*\\n*', '')
const str = `('BAR', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC LON', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARC-OTC', 'BARCGB22XXX', 'B', '00010101', '99991231'),
('BARINTL', 'BARCGB33XXX', 'B', '00010101', '99991231'),
('BCIEXUS', 'MLPFUS31XXX', 'B', '00010101', '99991231')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}