# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*\(\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*\s*(?:'[-\/a-zA-Z 0-9]{1,40}')\,\s*(?:'[ifbIFB]{1}')\,\s*(?:'[0-9]{8}')\,\s*(?:'[0-9]{8}')\)\s*\,\s*\n*"
test_str = ("('BAR', 'BARCGB22XXX', 'B', '00010101', '99991231'), \n"
"('BARC LON', 'BARCGB22XXX', 'B', '00010101', '99991231'), \n"
"('BARC-OTC', 'BARCGB22XXX', 'B', '00010101', '99991231'), \n"
"('BARINTL', 'BARCGB33XXX', 'B', '00010101', '99991231'), \n"
"('BCIEXUS', 'MLPFUS31XXX', 'B', '00010101', '99991231')")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.