$re = '/(?:.*[\s])(\d.*)(?:[\s].*)/';
$str = 'Общая сумма заказа: 470 ₽';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;