const regex = /(?:.*[\s])(\d.*)(?:[\s].*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*[\\s])(\\d.*)(?:[\\s].*)', 'g')
const str = `Общая сумма заказа: 470 ₽`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);