using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*[\s])(\d.*)(?:[\s].*)";
string substitution = @"$1";
string input = @"Общая сумма заказа: 470 ₽";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}