package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:.*[\s])(\d.*)(?:[\s].*)`)
var str = `Общая сумма заказа: 470 ₽`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}