// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:'[^']*'|"[^"]*"|(\((?:[^()]++|(?1))*\))|[^'",])+"#).unwrap();
let string = "lorem ipsum=123,delor='1,456',sit=\"123,456\",amet=xxx(2,3),\"consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}