package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:'[^']*'|"[^"]*"|(\((?:[^()]++|(?1))*\))|[^'",])+`)
var str = `lorem ipsum=123,delor='1,456',sit="123,456",amet=xxx(2,3),"consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}