using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'[^']*'|""[^""]*""|(\((?:[^()]++|(?1))*\))|[^'"",])+";
string input = @"lorem ipsum=123,delor='1,456',sit=""123,456"",amet=xxx(2,3),""consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}