re = /^([a-zA-Z]{2,3})(([\-\_][a-zA-Z]{4})+)?([\-\_][a-zA-Z]{2})?([\-\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\=[a-zA-Z\-\_]*[;]?)*)?/m
str = 'fr
fr-fr
fr_FR
zh_Hans_CN
zh-hans-cn
fr@collation=phonebook;calendar=islamic-civil
sr_Latn_RS_REVISED@currency=USD
en_IE@currency=IEP
en_IE_PREEURO
sr_Hans_Latn_RS_REVISED@currency=USD
fre_FR
und
fr@collation=phonebook;calendar=islamic-civil;currency=IEP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end