#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]{2,3})(([\-\_][a-zA-Z]{4})+)?([\-\_][a-zA-Z]{2})?([\-\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\=[a-zA-Z\-\_]*[;]?)*)?"
Local $sString = "fr" & @CRLF & _
"fr-fr" & @CRLF & _
"fr_FR" & @CRLF & _
"zh_Hans_CN" & @CRLF & _
"zh-hans-cn" & @CRLF & _
"fr@collation=phonebook;calendar=islamic-civil" & @CRLF & _
"sr_Latn_RS_REVISED@currency=USD" & @CRLF & _
"en_IE@currency=IEP" & @CRLF & _
"en_IE_PREEURO" & @CRLF & _
"sr_Hans_Latn_RS_REVISED@currency=USD" & @CRLF & _
"fre_FR" & @CRLF & _
"und" & @CRLF & _
"fr@collation=phonebook;calendar=islamic-civil;currency=IEP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")