using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]{2,3})(([\-\_][a-zA-Z]{4})+)?([\-\_][a-zA-Z]{2})?([\-\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\=[a-zA-Z\-\_]*[;]?)*)?";
string input = @"fr
fr-fr
fr_FR
zh_Hans_CN
zh-hans-cn
fr@collation=phonebook;calendar=islamic-civil
sr_Latn_RS_REVISED@currency=USD
en_IE@currency=IEP
en_IE_PREEURO
sr_Hans_Latn_RS_REVISED@currency=USD
fre_FR
und
fr@collation=phonebook;calendar=islamic-civil;currency=IEP";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}