use strict;
my $str = '<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写';
my $regex = qr/img.*?title="([^"]+)"\s*src="([^"]+)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}