const regex = /img.*?title="([^"]+)"\s*src="([^"]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('img.*?title="([^"]+)"\\s*src="([^"]+)"', 'g')
const str = `<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}