using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"img.*?title=""([^""]+)""\s*src=""([^""]+)""";
string input = @"<img alt=""大气超级品牌日活动宣传海报"" title=""大气超级品牌日活动宣传海报"" src=""http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226"" width=""226"" height=""546"" /> 请问只取title和src 应该怎么写<img alt=""大气超级品牌日活动宣传海报"" title=""大气超级品牌日活动宣传海报"" src=""http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226"" width=""226"" height=""546"" /> 请问只取title和src 应该怎么写<img alt=""大气超级品牌日活动宣传海报"" title=""大气超级品牌日活动宣传海报"" src=""http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226"" width=""226"" height=""546"" /> 请问只取title和src 应该怎么写<img alt=""大气超级品牌日活动宣传海报"" title=""大气超级品牌日活动宣传海报"" src=""http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226"" width=""226"" height=""546"" /> 请问只取title和src 应该怎么写<img alt=""大气超级品牌日活动宣传海报"" title=""大气超级品牌日活动宣传海报"" src=""http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226"" width=""226"" height=""546"" /> 请问只取title和src 应该怎么写<img alt=""大气超级品牌日活动宣传海报"" title=""大气超级品牌日活动宣传海报"" src=""http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226"" width=""226"" height=""546"" /> 请问只取title和src 应该怎么写";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}