import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "img.*?title=\"([^\"]+)\"\\s*src=\"([^\"]+)\"";
final String string = "<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}