import Foundation
let pattern = #"(\(([^)]*)\))(\s?)(([0-9]{0,5})(\-)?([0-9]{0,4}))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(13)300-413"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)