$re = '/(\(([^)]*)\))(\s?)(([0-9]{0,5})(\-)?([0-9]{0,4}))$/';
$str = '(13)300-413';
$subst = "$2 $4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;