$re = '/\b(?:happ+y+\s*b(irthda|da?)y+|HBD)\b(?:\s*to\s*([^\d\s]+))?/mi';
$str = 'happyyy birthdayy
happy bdy
happy hbd happy bdy happy birthday birthday happy hpy birthday
hapy birthday';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);