const regex = /\b(?:happ+y+\s*b(irthda|da?)y+|HBD)\b(?:\s*to\s*([^\d\s]+))?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:happ+y+\\s*b(irthda|da?)y+|HBD)\\b(?:\\s*to\\s*([^\\d\\s]+))?', 'gmi')
const str = `happyyy birthdayy
happy bdy
happy hbd happy bdy happy birthday birthday happy hpy birthday
hapy birthday`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}