using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:happ+y+\s*b(irthda|da?)y+|HBD)\b(?:\s*to\s*([^\d\s]+))?";
string input = @"happyyy birthdayy
happy bdy
happy hbd happy bdy happy birthday birthday happy hpy birthday
hapy birthday";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}