import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:happ+y+\\s*b(irthda|da?)y+|HBD)\\b(?:\\s*to\\s*([^\\d\\s]+))?";
final String string = "happyyy birthdayy\n"
+ "happy bdy\n"
+ "happy hbd happy bdy happy birthday birthday happy hpy birthday\n"
+ "hapy birthday";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}