re = /(?mixs)
/
str = '1-ASCII:
1.1-Los 95 caracteres ASCII imprimibles:
!"#$%&\'()*+,-./
0123456789:;<=>?@
ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`
abcdefghijklmnopqrstuvwxyz{|}~~
1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú
ñÑ ÿ
2-Algunos Unicode no no ASCII:∫∬∭∰∰'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end