#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mixs)" & @CRLF & _
""
Local $sString = "1-ASCII:" & @CRLF & _
"1.1-Los 95 caracteres ASCII imprimibles:" & @CRLF & _
" !"#$%&'()*+,-./" & @CRLF & _
"0123456789:;<=>?@" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz{|}~~" & @CRLF & _
"1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú" & @CRLF & _
"ñÑ ÿ" & @CRLF & _
"2-Algunos Unicode no no ASCII:∫∬∭∰∰"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")