const regex = new RegExp('(?mixs)
', 'g')
const str = `1-ASCII:
1.1-Los 95 caracteres ASCII imprimibles:
!"#\$%&'()*+,-./
0123456789:;<=>?@
ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_\`
abcdefghijklmnopqrstuvwxyz{|}~~
1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú
ñÑ ÿ
2-Algunos Unicode no no ASCII:∫∬∭∰∰`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}