package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mixs)
`)
var str = `1-ASCII:
1.1-Los 95 caracteres ASCII imprimibles:
!"#$%&'()*+,-./
0123456789:;<=>?@
ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_\`
abcdefghijklmnopqrstuvwxyz{|}~~
1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú
ñÑ ÿ
2-Algunos Unicode no no ASCII:∫∬∭∰∰`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}