$re = '/^(?!.*?(16x16|250x250|50x50))(?:\w+|.*)/mi';
$str = 'Matches containing some directory names,
but what about the oposite? having "good|big|aproved" directorys? and then hiding the others?
16x16
20x20
250x250
50x50
flobee
x
xx
abc/cdr
--> to hide >--
16x16/xxxx
/16x16/xxxx
path/16x16/xxxx
250x250/xxxx
/250x250/xxxx
good/16x16/xxxx
/good/16x16/xxxx
big/16x16/xxxx
/big/16x16/xxxx
--< to hide <--
good/xxxx
/good/xxxx
big/xxxx
/big/xxxx
/a/b/c/xxx.file
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);