const regex = /^(?!.*?(16x16|250x250|50x50))(?:\w+|.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?(16x16|250x250|50x50))(?:\\w+|.*)', 'gmi')
const str = `Matches containing some directory names,
but what about the oposite? having "good|big|aproved" directorys? and then hiding the others?
16x16
20x20
250x250
50x50
flobee
x
xx
abc/cdr
--> to hide >--
16x16/xxxx
/16x16/xxxx
path/16x16/xxxx
250x250/xxxx
/250x250/xxxx
good/16x16/xxxx
/good/16x16/xxxx
big/16x16/xxxx
/big/16x16/xxxx
--< to hide <--
good/xxxx
/good/xxxx
big/xxxx
/big/xxxx
/a/b/c/xxx.file
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}