import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*?(16x16|250x250|50x50))(?:\\w+|.*)";
final String string = "Matches containing some directory names, \n"
+ "but what about the oposite? having \"good|big|aproved\" directorys? and then hiding the others?\n"
+ "16x16\n"
+ "20x20\n"
+ "250x250\n"
+ "50x50\n"
+ "flobee\n"
+ "x\n"
+ "xx\n"
+ "abc/cdr\n"
+ "--> to hide >-- \n"
+ "16x16/xxxx\n"
+ "/16x16/xxxx\n"
+ "path/16x16/xxxx\n"
+ "250x250/xxxx\n"
+ "/250x250/xxxx\n"
+ "good/16x16/xxxx\n"
+ "/good/16x16/xxxx\n"
+ "big/16x16/xxxx\n"
+ "/big/16x16/xxxx\n"
+ "--< to hide <-- \n\n"
+ "good/xxxx\n"
+ "/good/xxxx\n"
+ "big/xxxx\n"
+ "/big/xxxx\n"
+ "/a/b/c/xxx.file\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}