#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*?(16x16|250x250|50x50))(?:\w+|.*)"
Local $sString = "Matches containing some directory names, " & @CRLF & _
"but what about the oposite? having "good|big|aproved" directorys? and then hiding the others?" & @CRLF & _
"16x16" & @CRLF & _
"20x20" & @CRLF & _
"250x250" & @CRLF & _
"50x50" & @CRLF & _
"flobee" & @CRLF & _
"x" & @CRLF & _
"xx" & @CRLF & _
"abc/cdr" & @CRLF & _
"--> to hide >-- " & @CRLF & _
"16x16/xxxx" & @CRLF & _
"/16x16/xxxx" & @CRLF & _
"path/16x16/xxxx" & @CRLF & _
"250x250/xxxx" & @CRLF & _
"/250x250/xxxx" & @CRLF & _
"good/16x16/xxxx" & @CRLF & _
"/good/16x16/xxxx" & @CRLF & _
"big/16x16/xxxx" & @CRLF & _
"/big/16x16/xxxx" & @CRLF & _
"--< to hide <-- " & @CRLF & _
"" & @CRLF & _
"good/xxxx" & @CRLF & _
"/good/xxxx" & @CRLF & _
"big/xxxx" & @CRLF & _
"/big/xxxx" & @CRLF & _
"/a/b/c/xxx.file" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")