re = /^(join|j) https:\/\/discord\.gg\/([A-Za-z0-9]+)$/
str = 'join https://discord.gg/daze1313890DsqdjazhSHQKDHAZE'
# Print the match result
str.match(re) do |match|
puts match.to_s
end