using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(join|j) https://discord\.gg/([A-Za-z0-9]+)$";
string input = @"join https://discord.gg/daze1313890DsqdjazhSHQKDHAZE";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}