package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^(join|j) https://discord\.gg/([A-Za-z0-9]+)$`)
var str = `join https://discord.gg/daze1313890DsqdjazhSHQKDHAZE`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}