$re = '/^(join|j) https://discord\.gg/([A-Za-z0-9]+)$/s';
$str = 'join https://discord.gg/daze1313890DsqdjazhSHQKDHAZE';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);