$re = '/^(?<project>\w+)-(?<core>\d+\.x)-(?<major>\d+)\.(?<patch>[\dx]+)[-\.]?(?<extra>[^\.]+)?\.(tar\.gz|tgz)$
/m';
$str = 'pkgdeploy-7.x-1.2.1.tar.gz
styles-7.x-2.x-dev.tar.gz
esi-7.x-3.0-alpha1+11-dev.tar.gz
views-7.x-2.1.tar.gz
views_ui-7.x-2.1.tar.gz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);